Your Account
    Log into your account here:
       Forgot Password

    Not registered? Sign Up for free
    Registration allows you to keep track of all your content and comments, save bookmarks, and post in all our forums.
Mobile

The Sims FreePlay

Can't build buildings (says I have a building under construction

 
Question asked by Guest on
Last Modified:

Can't build buildings (says I have a building under construction

I have the Saddle Update and I can no longer build any non-house buildings. It keeps saying I have another building under construction (I don't). I haven't used any cheats, it just seems to be bugged.

Has anyone encountered this and found a fix?

Add your answer

Please be as detailed as you can when making an answer. Answers that are too short or not descriptive are usually rejected.

Please do not use this box to ask a question, it will be rejected - this box is for answers ONLY. If you want to ask a question for this game, please use the ask a question box which is above on the right.

Accept submission terms View Terms

You are not registered / logged in.

If you would like to ne notified if/when we have added this answer to the site please enter your email address.

We will only use this address to email the confirmation for this answer.

 

 

Answers
CMBF answered:

When the game gets bugged like this the only way to fix it is to uninstall and then reinstall the game. Or you can submit an official help request through the game website, but the results from that are mixed.

Showing latest replies - show all (19)
Guest said: 6th Mar 2017 | REPORT
I have problem with a constructions on a sea voyage..my task to build volleyball expired and it says all the time that I have something under the construction..What can I do? I askd ea game support team and they didn't solve my problem. I can't uninstal because I've made a very good city and progress.
Guest said: 22nd Mar 2017 | REPORT
THANK YOU ... NOW I CAN BUILD AGAINN.. THERE SOMETHING IN STABLE @RoxyRox124
Guest said: 14th Jul 2017 | REPORT
I can't build the art gallery. claims Im building promotions r us
Guest said: 25th Nov 2017 | REPORT
I did the uninstall and reinstall and i don't recommend it at all. I lost almost all my progress along with $20 worth of sp and lp and $100,000 simoleons and birthday cake disappeared


CMBF answered:

Check the buildings on the mainland and the ones on the island - check to see if you have a lot that is in the final phase of being added.

Showing all replies
Guest said: 6th Jul 2017 | REPORT
They keep saying Sorcerous supplies is already under construction in sim town when I wanted to buy the babies store what does that mean
Guest said: 13th Jan 2018 | REPORT
Same!



Guest answered:

Double check all your buildings and especially the Stables. For me, my stable was built but it needed to be clicked on to finish it completely (it was kind of flashing). Hope that helps!

Showing latest replies - show all (9)
Guest said: 21st Aug 2016 | REPORT
How to build the elementary school when i already build a stables?? Please help me!!!!!
Guest said: 24th Aug 2016 | REPORT
I'm gonna try to powering my phone off and see if that works
Guest said: 4th Sep 2016 | REPORT
I'm no idea hmmm..... OK fine uninstall sims game...
CuteBaby Love said: 10th Mar 2017 | REPORT
I think i found the way because this is what happend whit my game...so i couldnt build because this note : cant build cuz stable is under construction
So i went to check my horse stable and there was no stables under construction so i try to click on every bubble....nothing...
But this worked
1.unninstall sims
2.Install it again from googlePlay
3.Load your game
4.Try to build again(it should still saying that there is stable on the construction but this time it was sayin stable IN stable)
5.so i went back to horse stables..one of the stage was flashing so I clicked on that.
6.Added two horses and clicked everything...
And than it worked...
Now I still play and build


Guest answered:

I HAV checked everywhere and I havnt got any still building and it still says that 😕



Guest answered:

So becouse I was level 23 I didnt want to lose everything I played so.....I was looking for answer
And I did find it!
1.I deleted the simsfreeplay
2.Went on google play and install the simsfreeplay again
3.becouse in mine was saying"cant build becouse stage is unde construction" I went to sthe Horse stage and added Horses in all of my stages and than it works.... I was looking for that for two days and finaly it works again try to fix it somehow like I did
Now I'm still playing and building

Showing all replies
Guest said: 5th Dec 2019 | REPORT
i already added all the horses but i still cant build..
Guest said: 5th Dec 2019 | REPORT
i already added all the horses but i still cant build..


deean_ong answered:

It happens on me also,actually before I tried to build the socerous supply,I tried to download the world of friend of mine from The Party Boat,but I don't have wifi so I pause it,I'm wondering if that is the issue why my Sorcerous Supplies tower building can't be done yet,it's already two days since I build t.
I'm going to try to finish my friend's world download,gotta find if it helps



Guest answered:

I can’t buy the baby store it keeps saying it’s under constructions



 

For more questions for The Sims FreePlay check out the question page where you can search or ask your own question.


The Sims FreePlay Guide
 


 
Need Answers?
Ask a question for The Sims FreePlay

Your Question
Please give as much detail as possible.
View Terms



Ask a question for a different game.