Can't build buildings (says I have a building under construction

 
 
 
Guest asks: Added May 16th 2014, ID #330916

Can't build buildings (says I have a building under construction

I have the Saddle Update and I can no longer build any non-house buildings. It keeps saying I have another building under construction (I don't). I haven't used any cheats, it just seems to be bugged.

Has anyone encountered this and found a fix?
 
 
Ask.com and get
 
 
Add your answerAnswers for this Question
 
CMBF answered:
Added 18th May 2014, ID #624755
When the game gets bugged like this the only way to fix it is to uninstall and then reinstall the game. Or you can submit an official help request through the game website, but the results from that are mixed.
 
Showing latest comments
show all (6)
Guest said: 28th Aug 2014 | REPORT
I uninstalled & reinstalled the game as this has happened to me, & it still doesn't work
Guest said: 1st Oct 2014 | REPORT
Mine isn't working either...I deleted it and reinstalled it too
RoxyRox124 said: 25th Jan 2015 | REPORT
I went to the stables and click on everything I notice one of the add horse simbol was somewhat flashy I guess it finished but I did not finalize it and it WORKED!!! I recommend to do the same thing and make sure there's nothing left to click on.
Guest said: 30th Jan 2015 | REPORT
Went to stable and click on everything as Roxy Road 24 said......It worked!! Thanks :-)
 
 
 
CMBF answered:
Added 18th May 2014, ID #624796
Check the buildings on the mainland and the ones on the island - check to see if you have a lot that is in the final phase of being added.
 
 
 
 
Guest answered:
Added 28th May 2014, ID #625974
Double check all your buildings and especially the stables. For me, my stable was built but it needed to be clicked on to finish it completely (it was kind of flashing). Hope that helps!
 
Showing all comments
Guest said: 12th Sep 2014 | REPORT
I have the same problem! :(
Guest said: 21st Nov 2014 | REPORT
omg thank you so much. This helped alot
Guest said: 13th Jan 2015 | REPORT
I checked everywhere and it still says that help!!
 
 
 
Guest answered:
Added 24th Dec 2014, ID #650624
I HAV checked everywhere and I havnt got any still building and it still says that 😕
 
 
 
 
 

Add your answer

Please be as detailed as you can when making an answer. Answers that are too short or not descriptive are usually rejected.

Please do not use this box to ask a question, it will be rejected - this box is for answers ONLY. If you want to ask a question for this game, please use the ask a question box which is above on the right.


BB Codes Guide

Accept submission terms View Terms

You are not registered / logged in.
If you would like to ne notified if/when we have added this answer to the site please enter your email address.
We will only use this address to email the confirmation for this answer.

 

 
Who's Playing
Questions?
Game Guide
 
Game Talk
 
LINKS FROM THE WEB..
 
 
 

♥ Like it :: Share it

 
Have a question?
Ask a question for The Sims FreePlay

Question Guidelines

 
Your Question (short version)
Question Description (more details)

Please complete both boxes

You are not registered / logged in.
If you would like to receive an email to let you know if/when we have added this question to the site please enter your email address.

We will only use this address to email the confirmation for this question.

Accept submission terms View Terms



Ask a question for another game.
 
 
 
AppGamer Reviews
Order and Chaos Online - 4.6
A mobile MMORPG that thrives: Order & Chaos..
Loop Drive: Crash Race - 3.0
Loop Drive: Crash Race Review Loop Drive is..
Rise of Darkness - 4.3
Rise of Darkness: Hack Hack Here, Slash Sla..