Google+  
 

Question for The Sims FreePlay

 
 
Guest asks: Added Mar 21st 2012, ID #254521

Question for The Sims FreePlay

When I went to the store n tried to buy the simoleons, I always get the server timed out, how to solve this problem?
 
 
Ask.com and get
 
 
Add your answerAnswers for this Question
 
Guest answered: Added 22nd Mar 2012, ID #491890
Sounds like your Internet connection may be slow, or just a problem with the store, I would try another time, or try when you can connect by wifi instead of your phone/iPads 3g/4g internet
 
Showing latest comments | show all (14)
Guest said: 16th May 2014, ID #384738 | REPORT
When i connect to WiFi, it still won't let me buy!!!
Guest said: 13th Sep 2014, ID #447374 | REPORT
It lets me on other games like Frozen's free fall, Subway Surfers, Temple run 1&2, but I tried in on sims and it doesn't let me. Is there a problem with their servers? I have been noticing that I'm not the only one with the same problem
Guest said: 18th Sep 2014, ID #449154 | REPORT
Mines the same way!! Ivr restarted my device and nothing. Yet all of my other games/connections are fine
Guest said: 18th Nov 2014, ID #473267 | REPORT
I can't get it to work I will cry if I don't I love the sims free play
 
 
 
Guest answered: Added 11th Oct 2012, ID #544067
It's not working for me ether Please HELP!!!!!!! I already tried restarting my Ipad (I did not work)
 
 
 
 
Guest answered: Added 16th Oct 2012, ID #545060
Mines doing the same thing it sucks and I have tryed like everything to fix it
 
 
 
 
Guest answered: Added 30th Oct 2012, ID #547788
I have the same freakin problem.. But I fixed it ! I dnt hw but I wanted to upgrade my sims freeplay to the halloween upgrade and it said to check my date and time settings... So I did . And I changed it back to the right date. Becuase it was wrong because of the. Sim cheat I used. So I went to the app store I could download!!!! And iphefore that I checked my sims and I opened the online store and I got in...it's just basic furniture ...hope this helps !!!! Inoriced a lot of people hadve the same problme...
 
 
 
 
Guest answered: Added 26th Dec 2012, ID #559539
I have the same problem. Checked date and time but it still doesn't work! It happened since the first time I got in the store. It just never lets me buy!
 
 
 
 
Guest answered: Added 28th Jun 2014, ID #630318
This happened me aswell and it was so annoying.
But I turned off my device then turned it on again
And it worked........ I was able to buy simoleons.hope this works👍
 
Showing all comments
Guest said: 18th Sep 2014, ID #449135 | REPORT
I tried that didn't work!
 
 
 
Guest answered: Added 5th Dec 2014, ID #648575
It probably just because your time and date (settings) are not on automatic. Try setting them back

 
 
 
 
 

Add your answer

Please be as detailed as you can when making an answer. Answers that are too short or not descriptive are usually rejected.

Please do not use this box to ask a question, it will be rejected - this box is for answers ONLY. If you want to ask a question for this game, please use the ask a question box which is above on the right.


BB Codes Guide

Accept submission terms View Terms

You are not registered / logged in.
If you would like to ne notified if/when we have added this answer to the site please enter your email address.
We will only use this address to email the confirmation for this answer.

 

 
Who's Playing
Questions?
Game Guide
Achievements
 
Game Talk
LINKS FROM THE WEB..
 
 

Have a question?