Google+  
 

Question for The Sims FreePlay

 
 
deeseaton asks: Added Mar 18th 2013, ID #303314

Question for The Sims FreePlay

I used the 'date cheat' and was building a children's store. Now- even after latest update the building is stuck on 100% and will not complete. Each day that I go on there I find -Xamount of seconds next to the building yet it still does not complete also the amount of LP I need to complete it keeps rising and I cannot cancel the build. Please help as I am on level 18 and do not want to delete it and start again. I have tried rebooting and switching of iphone to no avail.
 
 
Ask.com and get
 
 
Add your answerAnswers for this Question
 
Guest answered: Added 19th Mar 2013, ID #577573
Go back to the day you started building the centre and it should go back. I had the same problem when I time-travelled and that fixed it for me. Otherwise you could use lifepoint to finish it.
 
 
 
 
Guest answered: Added 22nd Jun 2013, ID #593300
I have the same problem too but going back to that date won't work

 
 
 
 
 

Add your answer

Please be as detailed as you can when making an answer. Answers that are too short or not descriptive are usually rejected.

Please do not use this box to ask a question, it will be rejected - this box is for answers ONLY. If you want to ask a question for this game, please use the ask a question box which is above on the right.


BB Codes Guide

Accept submission terms View Terms

You are not registered / logged in.
If you would like to ne notified if/when we have added this answer to the site please enter your email address.
We will only use this address to email the confirmation for this answer.

 

 
Who's Playing
Questions?
Game Guide
Achievements
 
Game Talk
LINKS FROM THE WEB..
 
 

More Questions
 
Have a question?