Google+  
 

vampire cure quest help bloodgrass

 
 
Art17 asks: Added Jan 27th 2008, ID #108229

vampire cure quest help bloodgrass

I gave the lady everything she ask for but she wont take the bloodgrass. I have about ten of them that I got in the plains of oblivion. Need help thanks
 
 
Ask.com and get
 
 
Add your answerAnswers for this Question
 
Towelee answered: Added 7th Apr 2008, ID #247462
That's weird the only thing I reconmend is that you drop all but 2 of them revist her later and if that doesn't work you should go back to oblivion and gather more.
 
 
 
 
deoraven answered: Added 7th Jun 2008, ID #259412
There is a BUG in the game!! When you give the witch the ingredients OUT of order (as they appear on the screen) a bug occurs and she dosent acknowledge the rest of your ingredients....Almost ALL gamers got screwed on dat one....i personally don't mind being a Vampire....but if YOU do....you WONT be able to be cured unless to restart a game and give her the ingredients in order....sorry thought you should know...
 
Showing all comments
Guest said: 15th Jul 2010, ID #4532 | REPORT
r u sure..??? coz i dont wanna start all over damnit....r u sure tho?
 
 
 
SUPERMAN5 answered: Added 3rd Sep 2008, ID #280551
Make sure to give them in order as she told you to get.
 
 
 
 
Guest answered: Added 29th Jul 2010, ID #344499
ive read that there is a bug on the game so if you want to give her the blood grass buy the normal game and put your character on it

 
 
 
 
Guest answered: Added 15th Aug 2010, ID #349615
Wow are you kidding me i did all that just to have to restart the game? That sucks dood im just going to be a vampire then cause im not going back either that or just wait till i get the game of the year edition
 
Showing all comments
Guest said: 16th Jun 2012, ID #153320 | REPORT
dosent work
Guest said: 16th Jun 2013, ID #290612 | REPORT
no you can just give her the argonian blood then give her the blood grass
 
 
 
Guest answered: Added 15th Aug 2010, ID #349617
I gave her the Garlic then the Nightshade and now it still wont let me give it to her
 
 
 
 
Guest answered: Added 5th Sep 2010, ID #354438
you have to set the PS3 to another language (eg spanish)... she will accept the bloodgrass, save and reset the language.... it works but... Shivering Isles resets too...
 
 
 
 
Guest answered: Added 13th Oct 2010, ID #360832
language trick worked!
 
 
 
 
Guest answered: Added 10th Nov 2010, ID #366100
amazing how did you figure out the language thing
 
Showing all comments
Guest said: 14th Dec 2011, ID #95000 | REPORT
well done mate, saved me
 
 
 
Guest answered: Added 12th Feb 2011, ID #386726
Vampire Cure Bug/Glitch..
(Melisande won't accept 2 Bloodgrass)

**Workaround**

1) Create new save outside her hut.

2) Quit game and go into Ps3 settings. Change language to 'Deutsch'

3) Load game and enter hut. Talk to Melisande and she will now accept the 2 Bloodgrass or "Blutgras".

4) Exit the hut to cause an Autosave. Then change settings back to english and reload game.

5) Complete the quest to obtain Vampire Cure.
 
Showing latest comments | show all (9)
Guest said: 3rd Aug 2011, ID #63816 | REPORT
guys a NEW save is required
Guest said: 26th Aug 2011, ID #70262 | REPORT
does this work for xbox 360 too ?? and how do you get on to those settings if it does?
Guest said: 2nd Nov 2011, ID #84556 | REPORT
This did not work for me ...

went into system settings > language > deutsch

(I also saved NEW) ... any more ideas? is there a patch for the ps3?
Guest said: 4th Nov 2011, ID #84955 | REPORT
Works!!! Thx bro
 
 
 
Guest answered: Added 19th Feb 2011, ID #388000
It's actually a glitch on the GOTY edition and the only way around it is to rent or borrow an original edition and finish the quest that way. The glitch is on the PC version as well but has been fixed. PS3 users haven't been so lucky. If you only have access to a GOTY edition...then, like me, you're stuck hiding from the sun indefinitely!
 
Showing all comments
Guest said: 19th Aug 2011, ID #68342 | REPORT
It DOES work on the PS3 GOTY (Platinum) edition. I found this site for the exact problem, and am so glad it got me past it. Thanks.
 
 
 
Guest answered: Added 1st Mar 2011, ID #390000
Don't listen to that guy all you have to do is change the language and try to give it to her then change it back real pain in the ass they shouldve fixed befor they released the stupid game who wants to spent days looking for all that and think you have it and she won't take it.

 
 
 
 
Guest answered: Added 1st Jun 2011, ID #409043
None of these are working for me
 
Showing all comments
Guest said: 13th Jun 2011, ID #49088 | REPORT
same here, and i dont own the goty version, i have the greatest hits one.... this is bullshit
Guest said: 6th Aug 2011, ID #64678 | REPORT
Thank you soo much :D! it worked
Guest said: 6th Aug 2011, ID #64679 | REPORT
Thank you soo much :D! it worked
 
 
 
Guest answered: Added 6th Aug 2011, ID #429524
The change language worked for me :D!!! Thank you sooo much'
 
 
 
 
Guest answered: Added 25th Sep 2011, ID #443067
Language trick only works for PAL European Oblivion..

 
 
 
 
Guest answered: Added 17th Nov 2011, ID #456358
Guys the only way I could get around this was to download Deepscorn Hollow and use the Purgeblood Salts from it. I'm afraid theres not much do-able if you are an XBOX 360 user like me, or just simply want to do the quest to gain permanent immunity, or whatever.
 
 
 
 
Guest answered: Added 30th Nov 2011, ID #460373
The language trick worked. Cheers mate :D
 
 
 
 
Guest answered: Added 28th Dec 2011, ID #467224
THX man it worked just change the system language
 
 
 
 
Submission removed pending moderation
 
Guest answered: Added 23rd Nov 2012, ID #552995
Ya I have the game of the year addition and the change language thing didn't work for me, and I tried about 10 times all with new save files :/ and I'm definitely not restarting the game or quest just to give her the ingrediants in order. If I were going to do that I would just try not to get the vampire disease altogether.
 
 
 
 
Guest answered: Added 3rd Jan 2013, ID #562109
There is a bug if you have completed the main story by the time you want to give her the bloodgrass than the option wont apear.
 
 
 
 
Guest answered: Added 10th Mar 2014, ID #619418
There was this one genious guy who gave me an answer and believe it or not it worked. Go to your ps3 main, change language to deutch and play the game again. You'll have to save your game before and after changin language, otherwise wont work. Try it out!
 
 
 
 
 

Add your answer

Please be as detailed as you can when making an answer. Answers that are too short or not descriptive are usually rejected.

Please do not use this box to ask a question, it will be rejected - this box is for answers ONLY. If you want to ask a question for this game, please use the ask a question box which is above on the right.


BB Codes Guide

Accept submission terms View Terms

You are not registered / logged in.
If you would like to ne notified if/when we have added this answer to the site please enter your email address.
We will only use this address to email the confirmation for this answer.

 

 
Who's Playing
Questions?
Game Guide
Trophies
 
Game Talk
LINKS FROM THE WEB..
 
 

Have a question?