Question for Nibiru: Age of Secrets

frustrated2 asks: Added Nov 17th 2010, ID #172425

Question for Nibiru: Age of Secrets

Ihave the code for the mechanical elavator, tried the ID first then the code, keeps saying somthing is wrong, but I can't figure out what, please help! and get
Add your answerAnswers for this Question
Guest answered: Added 18th Nov 2010, ID #367348
I just kept trying ID first then code, click paper with code on to the right of the machine next to keypad and it worked.

Add your answer

Please be as detailed as you can when making an answer. Answers that are too short or not descriptive are usually rejected.

Please do not use this box to ask a question, it will be rejected - this box is for answers ONLY. If you want to ask a question for this game, please use the ask a question box which is above on the right.

BB Codes Guide

Accept submission terms View Terms

You are not registered / logged in.
If you would like to ne notified if/when we have added this answer to the site please enter your email address.
We will only use this address to email the confirmation for this answer.


Who's Playing
Game Talk

Have a question?