Your Account
    Log into your account here:
       Forgot Password

    Not registered? Sign Up for free
    Registration allows you to keep track of all your content and comments, save bookmarks, and post in all our forums.
Follow the dark path or use the light
Mobile

go
SHARE

I have just done the november update and now the g..

 
 
 
ap2891 asks: Added Nov 8th 2012, ID #287037

Question for The Simpsons: Tapped Out

I have just done the november update and now the game wont let me log into my town ! I get as far as clicking on my user name then it just keeps taking me to the sorry please retry page I'm on level 23 and I don't want to loose my game or start over! Any one else had the same problem or no how I can fix it! I have tried closing the app on my phone and deleting and re instaling nothing seems to make a difference some oone please help!!!!!!!!!!!
 
 

 
Add your answer6 Answers for this Question
 
sjgottfried answered:
Added 8th Nov 2012, ID #549685
I'm having the same problem. You're not alone, but I don't know what to do either.
 
 
 
 
joerockhead answered:
Added 8th Nov 2012, ID #549820
Same for me. If they don't fix it can I just enter a new email address and sign it or do I have to create a new account? How do you do this? I don't remember how I created my first account.We are on level 23 and it's making us sick that we may have to start over.
 
 
 
 

Guest answered:
Added 9th Nov 2012, ID #549825
Same for me. Very annoying. I also had 2500 pieces of candy that just disappeared overnight with the update. I figured they might do that anyway, but the fact that my Halloween treats disappeared at the same time as an update/connectivity trick...really makes me mad!

 
 
 
 
Guest answered:
Added 9th Nov 2012, ID #549854
I am having the same problem and so is my daughter!! I can't visit any of my friends towns either!! I also keep losing donuts and I have spent about $60 on buying donuts, I'm too impatient to wait for things to finish up! And OMG why do the balloons cost so much money!!!!
 
 
 
 
Guest answered:
Added 9th Nov 2012, ID #549872
I have the same problem too!! I already logged in but when the game almost start, it suddenly shuts off :( what should I do?? Somebody please help :"(
 
 
 
 
Guest answered:
Added 9th Nov 2012, ID #549975
I tried deleting and re installing and still can't connect after 3 days but my daughters works fine. Very frustrating! Never had a problem before the thanksgiving update
 
 
 
 
 

Add your answer

Please be as detailed as you can when making an answer. Answers that are too short or not descriptive are usually rejected.

Please do not use this box to ask a question, it will be rejected - this box is for answers ONLY. If you want to ask a question for this game, please use the ask a question box which is above on the right.


BB Codes Guide

Accept submission terms View Terms

You are not registered / logged in.
If you would like to ne notified if/when we have added this answer to the site please enter your email address.
We will only use this address to email the confirmation for this answer.

 

 
 
 
 
More Questions
 
Need Answers?
Ask a question for The Simpsons: Tapped Out

Question Guidelines

 
Your Question (short version)

Question Description (more details)

Please complete both boxes

You are not registered / logged in.
If you would like to receive an email to let you know if/when we have added this question to the site please enter your email address.

We will only use this address to email the confirmation for this question.

View Terms



Ask a question for a different game.
 
Game Talk
Top 10 SideKick Characters
Top 10 SideKick Characters
10 Games with Great Graphics
10 Games with Great Graphics
Nintendo Switch price news and updates
Nintendo Switch price news and updates
VR Gaming in 2017
Ghost Recon: Wildlands BETA access
Gaming Tech on show at CES
Vote for Playstation Game of the Year
How to Get to Level 40 in Pokemon GO
Christmas deals and giveaways for World of Warships
Overwatch does the Winter Wonderland
 
 
AppGamer Reviews
Clash Royale - 5.0
Clash Royale Card Based Strategy Game From ..
Land Sliders - 4.5
Review: Change Your Perspective With Land S..
League of Stickmen - 4.3
Chaotic Fun The title of the game may deter..