Your Account
    Log into your account here:
       Forgot Password

    Not registered? Sign Up for free
    Registration allows you to keep track of all your content and comments, save bookmarks, and post in all our forums.
Follow the dark path or use the light
Mobile
go
Modern Combat 3: Fallen Nation Pack Shot

Modern Combat 3: Fallen Nation

SHARE

Why can't I buy weapons and items? Ever since I u..

 
Guest asks: Added May 8th 2012, ID #263219

Question for Modern Combat 3: Fallen Nation

Why can't I buy weapons and items?
Ever since I updated the game I bought a new weapon and now I can't buy any. I have the money and the needed rank but when I select what I want to buy the field doesn't light up and I can't buy the weapon. Any suggestions???

 

 
 
Guest answered:
Added 16th May 2012, ID #507291

I am not sure but this may be a bug. You should try deleting the game and reinstalling it. If this doesn't help then try making a new account this will not affect your single player although the first option will. If both of these don't work then I do not know what to do but you should try contacting gameloft. Thanks,
Nammyxo


 
Showing all comments
Guest said: 13th Sep 2014 | REPORT
I have the same problem whenever i got some xp in multiplayer i can't buy anything it force me to play next match but if i don't want to play then whatever points xp i got in previous match its all gone .. what the hell happened its been now 3 times . Any suggestions . Thanks in advance
 
 
 
Guest answered:
Added 8th Jun 2012, ID #513942

Hey, this happened to me to. I can't remember what I did but just to out of the game and delete the history. The green buy thing should be good to go.


 
 
 
 

Guest answered:
Added 26th Jun 2012, ID #518477

YEAH THE SAME IS HAPPENING TO ME RIGHT NOW! Thats why I'm looking online for answers.. I have about 35,ooo gold coins and I can't buy anything it's unbelievable! So should I just delete my browser history?


 
 
 
 
Guest answered:
Added 29th Aug 2012, ID #535509

Yo, fixed it..

Exit game

Hold down only button untill bar appears

Find app

Click red button

Re-open app.


 
 
 
 
Guest answered:
Added 18th Nov 2012, ID #551961

Same thing happen to me I wanted to buy a sniper rifle I have 10,370 coins and the rifle cost 7000. The button doesnt light up.


 
Showing all comments
Guest said: 14th Dec 2012 | REPORT
Just turn off your phone/ipod and go back and it will work!
Guest said: 2nd Jan 2013 | REPORT
Just delete to history. It worked for me!

 
 
 
Guest answered:
Added 8th Feb 2013, ID #569810

Delete it and reinstall it it's works for me now


 
Showing all comments
Guest said: 20th Apr 2013 | REPORT
thx
 
 
 
 

Add your answer

Please be as detailed as you can when making an answer. Answers that are too short or not descriptive are usually rejected.

Please do not use this box to ask a question, it will be rejected - this box is for answers ONLY. If you want to ask a question for this game, please use the ask a question box which is above on the right.


BB Codes Guide

Accept submission terms View Terms

You are not registered / logged in.
If you would like to ne notified if/when we have added this answer to the site please enter your email address.
We will only use this address to email the confirmation for this answer.

 

 
 
 
More Questions
 
Need Answers?
Ask a question for Modern Combat 3: Fallen Nation

Question Guidelines

 
Your Question (short version)

Question Description (more details)

Please complete both boxes

You are not registered / logged in.
If you would like to receive an email to let you know if/when we have added this question to the site please enter your email address.

We will only use this address to email the confirmation for this question.

View Terms



Ask a question for a different game.
 
Game Talk
Legendary Pokemon Coming To Pokemon GO This Summer?
Legendary Pokemon Coming To Pokemon GO This Summer?
Gym Overhaul Coming Soon To Pokemon GO?
Gym Overhaul Coming Soon To Pokemon GO?
Why Is Delibird STILL Not In Pokemon GO?!
Why Is Delibird STILL Not In Pokemon GO?!
April Game Releases 2017
Destiny 2 Worldwide Release Trailer and Release Date
Retro Royale
Destiny 2 Teaser arrives with more on the way
Guarantee Evolution Item Added To 7-Day Streak In Pokemon GO
No More Fake GPS Spoofing in Pokemon GO
Ash-Pikachus To Be Released Starting In April
 
AppGamer Reviews
Terraria. - 4.2
Terraria Since the sudden, explosive succes..
Cadenza: The Kiss of.. - 4.0
Power, Pleasure, Pain One of the more natur..
Land Sliders - 4.5
Review: Change Your Perspective With Land S..